Incorrect Authorization in packagist/pixelfed/pixelfed


GHSA-gccq-h3xj-jgvf, CVE-2024-25108

Package Slug



Incorrect Authorization


Pixelfed is an open source photo sharing platform. When processing requests authorization was improperly and insufficiently checked, allowing attackers to access far more functionality than users intended, including to the administrative and moderator functionality of the Pixelfed server. This vulnerability affects every version of Pixelfed between v0.10.4 and v0.11.9, inclusive. A proof of concept of this vulnerability exists. This vulnerability affects every local user of a Pixelfed server, and can potentially affect the servers' ability to federate. Some user interaction is required to setup the conditions to be able to exercise the vulnerability, but the attacker could conduct this attack time-delayed manner, where user interaction is not actively required. This vulnerability has been addressed in version 0.11.11. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Affected Versions

All versions starting from 0.10.4 before 0.11.11


Upgrade to version 0.11.11 or above.

Last Modified