CVE-2022-36032

Improper Input Validation in packagist/react/http

Identifiers

CVE-2022-36032, GHSA-w3w9-vrf5-8mx8

Package Slug

packagist/react/http

Vulnerability

Improper Input Validation

Description

ReactPHP HTTP is a streaming HTTP client and server implementation for ReactPHP. In ReactPHP's HTTP server component versions starting with 0.7.0 and prior to 1.7.0, when ReactPHP is processing incoming HTTP cookie values, the cookie names are url-decoded. This may lead to cookies with prefixes like __Host- and __Secure- confused with cookies that decode to such prefix, thus leading to an attacker being able to forge cookie which is supposed to be secure. This issue is fixed in ReactPHP HTTP version 1.7.0. As a workaround, Infrastructure or DevOps can place a reverse proxy in front of the ReactPHP HTTP server to filter out any unexpected Cookie request headers.

Affected Versions

All versions starting from 0.7.0 before 1.7.0

Solution

Upgrade to version 1.7.0 or above.

Last Modified

2022-09-12

source