CVE-2023-22730

Improper Input Validation in packagist/shopware/core

Identifiers

CVE-2023-22730, GHSA-8r6h-m72v-38fg

Package Slug

packagist/shopware/core

Vulnerability

Improper Input Validation

Description

Shopware is an open source commerce platform based on Symfony Framework and Vue js. In affected versions It was possible to put the same line item multiple times in the cart using the AP. The Cart Validators checked the line item's individuality and the user was able to bypass quantity limits in sales. This problem has been fixed with version 6.4.18.1. Users on major versions 6.1, 6.2, and 6.3 may also obtain this fix via a plugin.

Affected Versions

All versions before 6.4.18.1

Solution

Upgrade to version 6.4.18.1 or above.

Last Modified

2023-01-18

source