CVE-2023-22733

Insertion of Sensitive Information into Log File in packagist/shopware/core

Identifiers

CVE-2023-22733, GHSA-7cp7-jfp6-jh4f

Package Slug

packagist/shopware/core

Vulnerability

Insertion of Sensitive Information into Log File

Description

Shopware is an open source commerce platform based on Symfony Framework and Vue js. In affected versions the log module would write out all kind of sent mails. An attacker with access to either the local system logs or a centralized logging store may have access to other users accounts. This issue has been addressed in version 6.4.18.1. For older versions of 6.1, 6.2, and 6.3, corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version. Users unable to upgrade may remove from all users the log module ACL rights or disable logging.

Affected Versions

All versions before 6.4.18.1

Solution

Upgrade to version 6.4.18.1 or above.

Last Modified

2023-01-23

source