CVE-2023-22734

Improper Input Validation in packagist/shopware/core

Identifiers

CVE-2023-22734, GHSA-46h7-vj7x-fxg2

Package Slug

packagist/shopware/core

Vulnerability

Improper Input Validation

Description

Shopware is an open source commerce platform based on Symfony Framework and Vue js. The newsletter double opt-in validation was not checked properly, and it was possible to skip the complete double opt in process. As a result operators may have inconsistencies in their newsletter systems. This problem has been fixed with version 6.4.18.1. Users are advised to upgrade. Users unable to upgrade may find security measures are available via a plugin for major versions 6.1, 6.2, and 6.3. Users may also disable newsletter registration completely.

Affected Versions

All versions before 6.4.18.1

Solution

Upgrade to version 6.4.18.1 or above.

Last Modified

2023-01-23

source