CVE-2023-22732

Insufficient Session Expiration in packagist/shopware/platform

Identifiers

CVE-2023-22732, GHSA-59qg-93jg-236f

Package Slug

packagist/shopware/platform

Vulnerability

Insufficient Session Expiration

Description

Shopware is an open source commerce platform based on Symfony Framework and Vue js. The Administration session expiration was set to one week, when an attacker has stolen the session cookie they could use it for a long period of time. In version 6.4.18.1 an automatic logout into the Administration session has been added. As a result the user will be logged out when they are inactive. Users are advised to upgrade. There are no known workarounds for this issue.

Affected Versions

All versions before 6.4.18.1

Solution

Upgrade to version 6.4.18.1 or above.

Last Modified

2023-01-23

source