CVE-2022-24871

Server-Side Request Forgery (SSRF) in packagist/shopware/shopware

Identifiers

CVE-2022-24871, GHSA-7gm7-8q8v-9gf2

Package Slug

packagist/shopware/shopware

Vulnerability

Server-Side Request Forgery (SSRF)

Description

Shopware is an open commerce platform based on Symfony Framework and Vue. In affected versions an attacker can abuse the Admin SDK functionality on the server to read or update internal resources. Users are advised to update to the current version 6.4.10.1. For older versions of 6.1, 6.2, and 6.3, corresponding security measures are also available via a plugin. There are no known workarounds for this issue.

Affected Versions

All versions before 6.4.10.1

Solution

Upgrade to version 6.4.10.1 or above.

Last Modified

2022-05-01

source