CVE-2022-24873

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in packagist/shopware/shopware

Identifiers

CVE-2022-24873, GHSA-4g29-fccr-p59w

Package Slug

packagist/shopware/shopware

Vulnerability

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Description

Shopware is an open source e-commerce software platform. Prior to version 5.7.9, Shopware is vulnerable to non-stored cross-site scripting in the storefront. This issue is fixed in version 5.7.9. Users of older versions may attempt to mitigate the vulnerability by using the Shopware security plugin.

Affected Versions

All versions starting from 5.0.0 before 5.7.9

Solution

Upgrade to version 5.7.9 or above.

Last Modified

2022-05-01

source