CVE-2022-24879

Cross-Site Request Forgery (CSRF) in packagist/shopware/shopware

Identifiers

CVE-2022-24879, GHSA-pf38-v6qj-j23h

Package Slug

packagist/shopware/shopware

Vulnerability

Cross-Site Request Forgery (CSRF)

Description

Shopware is an open source e-commerce software platform. Versions prior to 5.7.9 is vulnerable to malfunction of cross-site request forgery (CSRF) token validation. Under certain circumstances, the CSRF tokens were not generated anew and not validated correctly. This issue is fixed in version 5.7.9. Users of older versions may attempt to mitigate the vulnerability by using the Shopware security plugin.

Affected Versions

All versions starting from 5.2.0 before 5.7.9

Solution

Upgrade to version 5.7.9 or above.

Last Modified

2022-05-01

source