CVE-2022-24892

Multiple valid tokens for password reset in Shopware in packagist/shopware/shopware

Identifiers

CVE-2022-24892, GHSA-3qrq-r688-vvh4

Package Slug

packagist/shopware/shopware

Vulnerability

Multiple valid tokens for password reset in Shopware

Description

Shopware is an open source e-commerce software platform. Starting with version 5.0.4 and before version 5.7.9, multiple tokens for password reset can be requested. All tokens can be used to change the password. This makes it possible for an attacker to take over the victim's account if they somehow gain access to the victims email account and find an unused password reset token in the emails. This issue is fixed in version 5.7.9.

Affected Versions

All versions starting from 5.0.4 before 5.7.9

Solution

Upgrade to version 5.7.9 or above.

Last Modified

2022-05-01

source