Identifier

CVE-2020-6165

Package Slug

packagist/silverstripe/graphql

Vulnerability

Incorrect Default Permissions

Description

The automatic permission-checking mechanism in the silverstripe/graphql module does not provide complete protection against lists that are limited (e.g., through pagination), resulting in records that should have failed a permission check being added to the final result set. GraphQL endpoints are configured by default (e.g., for assets), but the admin/graphql endpoint is access protected by default. This limits the vulnerability to all authenticated users, including those with limited permissions (e.g., where viewing records exposed through admin/graphql requires administrator permissions). However, if custom GraphQL endpoints have been configured for a specific implementation (usually under /graphql), this vulnerability could also be exploited through unauthenticated requests. This vulnerability only applies to reading records; it does not allow unauthorised changing of records.

Affected Versions

All versions starting from 3.2.0 before 3.3.0, all versions starting from 4.5.0 before 4.5.3

Solution

Upgrade to versions 3.3.0, 4.5.3 or above.

Last Modified

2020-07-28

source