CVE-2022-29254

Interpretation Conflict in packagist/silverstripe/silverstripe-omnipay

Identifiers

CVE-2022-29254, GHSA-48f2-m7jg-866x

Package Slug

packagist/silverstripe/silverstripe-omnipay

Vulnerability

Interpretation Conflict

Description

silverstripe-omnipay is a SilverStripe integration with Omnipay PHP payments library. For a subset of Omnipay gateways (those that use intermediary states like isNotification() or isRedirect()), if the payment identifier or success URL is exposed it is possible for payments to be prematurely marked as completed without payment being taken. This is mitigated by the fact that most payment gateways hide this information from users, however some issuing banks offer flawed 3DSecure implementations that may inadvertently expose this data. The following versions have been patched to fix this issue: 2.5.2, 3.0.2, 3.1.4, and 3.2.1. There are no known workarounds for this vulnerability.

Affected Versions

All versions starting before 2.5.2, all versions starting from 3.0.0 before 3.0.2, all versions starting from 3.1.0 before 3.1.4, all versions starting from 3.2.0 before 3.2.1

Solution

Upgrade to versions 2.5.2, 3.0.2, 3.1.4, 3.2.1 or above.

Last Modified

2022-06-19

source