CVE-2023-48217

Statamic CMS vulnerable to remote code execution via form uploads in packagist/statamic/cms

Identifiers

GHSA-2r53-9295-3m86, CVE-2023-48217

Package Slug

packagist/statamic/cms

Vulnerability

Statamic CMS vulnerable to remote code execution via form uploads

Description

Statamic is a flat-first, Laravel + Git powered CMS designed for building websites. In affected versions certain additional PHP files crafted to look like images may be uploaded regardless of mime type validation rules. This affects front-end forms using the "Forms" feature, and asset upload fields in the control panel. Malicious users could leverage this vulnerability to upload and execute code. This issue has been patched in versions 3.4.14 and 4.34.0. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Affected Versions

All versions before 3.4.14, all versions starting from 4.0.0 before 4.34.0

Solution

Upgrade to versions 3.4.14, 4.34.0 or above.

Last Modified

2023-11-16

source