CVE-2023-48219

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in packagist/tinymce/tinymce

Identifiers

CVE-2023-48219, GHSA-v626-r774-j7f8

Package Slug

packagist/tinymce/tinymce

Vulnerability

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Description

TinyMCE is an open source rich text editor. A mutation cross-site scripting (mXSS) vulnerability was discovered in TinyMCE’s core undo/redo functionality and other APIs and plugins. Text nodes within specific parents are not escaped upon serialization according to the HTML standard. If such text nodes contain a special character reserved as an internal marker, they can be combined with other HTML patterns to form malicious snippets. These snippets pass the initial sanitisation layer when the content is parsed into the editor body, but can trigger XSS when the special internal marker is removed from the content and re-parsed. his vulnerability has been patched in TinyMCE versions 6.7.3 and 5.10.9. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Affected Versions

All versions before 5.10.9, all versions starting from 6.0.0 before 6.7.3

Solution

Upgrade to versions 5.10.9, 6.7.3 or above.

Last Modified

2023-11-16

source