CVE-2013-4701

PHP OpenID Library Denial of Service vulnerability in packagist/typo3/cms

Identifiers

GHSA-5qp6-78pr-gv8c, CVE-2013-4701

Package Slug

packagist/typo3/cms

Vulnerability

PHP OpenID Library Denial of Service vulnerability

Description

Auth/Yadis/XML.php in PHP OpenID Library 2.2.2 and earlier allows remote attackers to read arbitrary files, send HTTP requests to intranet servers, or cause a denial of service (CPU and memory consumption) via XRDS data containing an external entity declaration in conjunction with an entity reference, related to an XML External Entity (XXE) issue.

Affected Versions

All versions starting from 6.2.0 before 6.2.6

Solution

Upgrade to version 6.2.6 or above.

Last Modified

2024-02-06

source