CVE-2021-21359

Asymmetric Resource Consumption (Amplification) in packagist/typo3/cms-core

Identifier

CVE-2021-21359

Package Slug

packagist/typo3/cms-core

Vulnerability

Asymmetric Resource Consumption (Amplification)

Description

Requesting invalid or non-existing resources via HTTP triggers the page error handler which again could retrieve content to be shown as error message from another page. This leads to a scenario in which the application is calling itself recursively - amplifying the impact of the initial attack until the limits of the web server are exceeded.

Affected Versions

All versions starting from 9.0.0 before 9.5.25, all versions starting from 10.0.0 before 10.4.14, all versions starting from 11.0.0 before 11.1.1

Solution

Upgrade to versions 9.5.25, 10.4.14, 11.1.1 or above.

Last Modified

2021-03-29

source