CVE-2022-31048

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in packagist/typo3/cms-core

Identifiers

GHSA-3r95-23jp-mhvg, CVE-2022-31048

Package Slug

packagist/typo3/cms-core

Vulnerability

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Description

TYPO3 is an open source web content management system. Prior to versions 8.7.47 ELTS, 9.5.34 ELTS, 10.4.29, and 11.5.11, the Form Designer backend module of the Form Framework is vulnerable to cross-site scripting. A valid backend user account with access to the form module is needed to exploit this vulnerability. TYPO3 versions 8.7.47 ELTS, 9.5.34 ELTS, 10.4.29, and 11.5.11 contain a fix for the problem.

Affected Versions

All versions starting from 8.0.0 before 8.7.47, all versions starting from 9.0.0 before 9.5.35, all versions starting from 10.0.0 before 10.4.29, all versions starting from 11.0.0 before 11.5.11

Solution

Upgrade to versions 8.7.47, 9.5.35, 10.4.29, 11.5.11 or above.

Last Modified

2022-06-19

source