CVE-2022-31050

Insufficient Session Expiration in packagist/typo3/cms-core

Identifiers

GHSA-wwjw-r3gj-39fq, CVE-2022-31050

Package Slug

packagist/typo3/cms-core

Vulnerability

Insufficient Session Expiration

Description

TYPO3 is an open source web content management system. Prior to versions 9.5.34 ELTS, 10.4.29, and 11.5.11, Admin Tool sessions initiated via the TYPO3 backend user interface had not been revoked even if the corresponding user account was degraded to lower permissions or disabled completely. This way, sessions in the admin tool theoretically could have been prolonged without any limit. TYPO3 versions 9.5.34 ELTS, 10.4.29, and 11.5.11 contain a fix for the problem.

Affected Versions

All versions starting from 9.0.0 before 9.5.35, all versions starting from 10.0.0 before 10.4.29, all versions starting from 11.0.0 before 11.5.11

Solution

Upgrade to versions 9.5.35, 10.4.29, 11.5.11 or above.

Last Modified

2022-06-19

source