CVE-2023-40611

Incorrect Authorization in pypi/apache-airflow

Identifiers

CVE-2023-40611

Package Slug

pypi/apache-airflow

Vulnerability

Incorrect Authorization

Description

Apache Airflow, versions before 2.7.1, is affected by a vulnerability that allows authenticated and DAG-view authorized Users to modify some DAG run detail values when submitting notes. This could have them alter details such as configuration parameters, start date, etc.

Users should upgrade to version 2.7.1 or later which has removed the vulnerability.

Affected Versions

All versions before 2.7.1

Solution

Upgrade to version 2.7.1 or above.

Last Modified

2023-09-14

source