CVE-2022-41703

Apache Superset's SQL Alchemy connector vulnerable to SQL Injection in pypi/apache-superset

Identifiers

CVE-2022-41703, GHSA-cxvp-3frm-3876

Package Slug

pypi/apache-superset

Vulnerability

Apache Superset's SQL Alchemy connector vulnerable to SQL Injection

Description

A vulnerability in the SQL Alchemy connector of Apache Superset allows an authenticated user with read access to a specific database to add subqueries to the WHERE and HAVING fields referencing tables on the same database that the user should not have access to, despite the user having the feature flag "ALLOWADHOCSUBQUERY" disabled (default value). This issue affects Apache Superset version 1.5.2 and prior versions and version 2.0.0.

Affected Versions

All versions up to 1.5.2, version 2.0.0

Solution

Upgrade to versions 1.5.3, 2.0.1 or above.

Last Modified

2023-01-23

source