CVE-2022-43717

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in pypi/apache-superset

Identifiers

CVE-2022-43717, GHSA-9f88-wg5r-947j

Package Slug

pypi/apache-superset

Vulnerability

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Description

Dashboard rendering does not sufficiently sanitize the content of markdown components leading to possible XSS attack vectors that can be performed by authenticated users with create dashboard permissions. This issue affects Apache Superset version 1.5.2 and prior versions and version 2.0.0.

Affected Versions

All versions up to 1.5.2, version 2.0.0

Solution

Upgrade to versions 1.5.3, 2.0.1 or above.

Last Modified

2023-01-23

source