CVE-2022-43718

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in pypi/apache-superset

Identifiers

CVE-2022-43718, GHSA-79x5-cv79-49rj

Package Slug

pypi/apache-superset

Vulnerability

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Description

Upload data forms do not correctly render user input leading to possible XSS attack vectors that can be performed by authenticated users with database connection update permissions. This issue affects Apache Superset version 1.5.2 and prior versions and version 2.0.0.

Affected Versions

All versions up to 1.5.2, version 2.0.0

Solution

Upgrade to versions 1.5.3, 2.0.1 or above.

Last Modified

2023-01-19

source