CVE-2020-15703

Path Traversal in pypi/aptdaemon

Identifier

CVE-2020-15703

Package Slug

pypi/aptdaemon

Vulnerability

Path Traversal

Description

There is no input validation on the Locale property in an apt transaction. An unprivileged user can supply a full path to a writable directory, which lets aptd read a file as root. Having a symlink in place results in an error message if the file exists, and no error otherwise. This way an unprivileged user can check for the existence of any files on the system as root.

Affected Versions

Version 1.1.1

Solution

Unfortunately, there is no solution available yet.

Last Modified

2020-11-18

source