CVE-2018-20998

Improper Restriction of Operations within the Bounds of a Memory Buffer in pypi/arrayfire

Identifiers

GHSA-69fv-gw6g-8ccg, CVE-2018-20998

Package Slug

pypi/arrayfire

Vulnerability

Improper Restriction of Operations within the Bounds of a Memory Buffer

Description

An issue was discovered in the arrayfire before 3.6.0. Addition of the repr() attribute to an enum is mishandled, leading to memory corruption.

Affected Versions

All versions starting from 0 before 3.6.0

Solution

Upgrade to version 3.6.0 or above.

Last Modified

2022-09-12

source