CVE-2022-24840

Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in pypi/django-s3file

Identifiers

CVE-2022-24840, GHSA-4w8f-hjm9-xwgf

Package Slug

pypi/django-s3file

Vulnerability

Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')

Description

django-s3file is a lightweight file upload input for Django and Amazon S3 . In versions prior to 5.5.1 it was possible to traverse the entire AWS S3 bucket and in most cases to access or delete files. If the AWS_LOCATION setting was set, traversal was limited to that location only. The issue was discovered by the maintainer. There were no reports of the vulnerability being known to or exploited by a third party, prior to the release of the patch. The vulnerability has been fixed in version 5.5.1 and above. There is no feasible workaround. We must urge all users to immediately updated to a patched version.

Affected Versions

All versions before 5.5.1

Solution

Upgrade to version 5.5.1 or above.

Last Modified

2022-06-19

source