CVE-2021-41945

Improper Input Validation in httpx in pypi/httpx

Identifiers

CVE-2021-41945, GHSA-h8pj-cxx2-jfg2

Package Slug

pypi/httpx

Vulnerability

Improper Input Validation in httpx

Description

Encode OSS httpx <=1.0.0.beta0 is affected by improper input validation in httpx.URL, httpx.Client and some functions using httpx.URL.copy_with.

Affected Versions

All versions up to 0.19.0, version 1.0.0

Solution

Upgrade to version 0.20.0 or above.

Last Modified

2022-05-01

source