CVE-2021-21332

Cross-site Scripting in pypi/matrix-synapse

Identifier

CVE-2021-21332

Package Slug

pypi/matrix-synapse

Vulnerability

Cross-site Scripting

Description

Synapse is a Matrix reference homeserver written in python. Matrix is an ecosystem for open federated Instant Messaging and VoIP. In Synapse, the password reset endpoint served via Synapse was vulnerable to cross-site scripting (XSS) attacks. The impact depends on the configuration of the domain that Synapse is deployed on, but may allow access to cookies and other browser data, CSRF vulnerabilities, and access to other resources served on the same domain or parent domains.

Affected Versions

All versions before 1.27.0

Solution

Upgrade to version 1.27.0 or above.

Last Modified

2021-04-02

source