CVE-2022-31506

Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in pypi/opendiamond

Identifiers

GHSA-x2pc-fqrw-hc7f, CVE-2022-31506

Package Slug

pypi/opendiamond

Vulnerability

Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')

Description

The cmusatyalab/opendiamond repository through 10.1.1 on GitHub allows absolute path traversal because the Flask send_file function is used unsafely.

Affected Versions

All versions up to 10.1.1

Solution

Unfortunately, there is no solution available yet.

Last Modified

2022-07-26

source