CVE-2020-14343

Improper Input Validation in pypi/pyyaml

Identifier

CVE-2020-14343

Package Slug

pypi/pyyaml

Vulnerability

Improper Input Validation

Description

A vulnerability was discovered in the PyYAML library, where it is susceptible to arbitrary code execution when it processes untrusted YAML files through the full_load method or with the FullLoader loader. Applications that use the library to process untrusted input may be vulnerable to this flaw. This flaw allows an attacker to execute arbitrary code on the system by abusing the python/object/new constructor. This flaw is due to an incomplete fix for CVE-2020-1747.

Affected Versions

All versions before 5.4

Solution

Upgrade to version 5.4 or above.

Last Modified

2021-02-18

source