CVE-2022-35974

Improper Input Validation in pypi/tensorflow

Identifiers

CVE-2022-35974, GHSA-vgvh-2pf4-jr2x

Package Slug

pypi/tensorflow

Vulnerability

Improper Input Validation

Description

TensorFlow is an open source platform for machine learning. If QuantizeDownAndShrinkRange is given nonscalar inputs for input_min or input_max, it results in a segfault that can be used to trigger a denial of service attack. We have patched the issue in GitHub commit 73ad1815ebcfeb7c051f9c2f7ab5024380ca8613. The fix will be included in TensorFlow 2.10.0. We will also cherrypick this commit on TensorFlow 2.9.1, TensorFlow 2.8.1, and TensorFlow 2.7.2, as these are also affected and still in supported range. There are no known workarounds for this issue.

Affected Versions

All versions starting from 2.7.0 before 2.7.2, all versions starting from 2.8.0 before 2.8.1, all versions starting from 2.9.0 before 2.9.1, version 2.10

Solution

Upgrade to versions 2.7.2, 2.8.1, 2.9.1 or above.

Last Modified

2022-09-19

source