CVE-2022-41899

Improper Input Validation in pypi/tensorflow

Identifiers

CVE-2022-41899, GHSA-27rc-728f-x5w2

Package Slug

pypi/tensorflow

Vulnerability

Improper Input Validation

Description

TensorFlow is an open source platform for machine learning. Inputs dense_features or example_state_data not of rank 2 will trigger a CHECK fail in SdcaOptimizer. We have patched the issue in GitHub commit 80ff197d03db2a70c6a111f97dcdacad1b0babfa. The fix will be included in TensorFlow 2.11. We will also cherrypick this commit on TensorFlow 2.10.1, 2.9.3, and TensorFlow 2.8.4, as these are also affected and still in supported range.

Affected Versions

All versions before 2.8.4, all versions starting from 2.9.0 before 2.9.3, version 2.10

Solution

Upgrade to versions 2.8.4, 2.9.3, 2.10.1 or above.

Last Modified

2022-11-22

source