CVE-2022-35971

Reachable Assertion in pypi/tensorflow-cpu

Identifiers

GHSA-9fpg-838v-wpv7, CVE-2022-35971

Package Slug

pypi/tensorflow-cpu

Vulnerability

Reachable Assertion

Description

TensorFlow is an open source platform for machine learning. If FakeQuantWithMinMaxVars is given min or max tensors of a nonzero rank, it results in a CHECK fail that can be used to trigger a denial of service attack. We have patched the issue in GitHub commit 785d67a78a1d533759fcd2f5e8d6ef778de849e0. The fix will be included in TensorFlow 2.10.0. We will also cherrypick this commit on TensorFlow 2.9.1, TensorFlow 2.8.1, and TensorFlow 2.7.2, as these are also affected and still in supported range. There are no known workarounds for this issue.

Affected Versions

All versions before 2.7.2, all versions starting from 2.8.0 before 2.8.1, all versions starting from 2.9.0 before 2.9.1

Solution

Upgrade to versions 2.7.2, 2.8.1, 2.9.1 or above.

Last Modified

2022-09-19

source