CVE-2023-32059

Function Call With Incorrect Order of Arguments in pypi/vyper

Identifiers

GHSA-ph9x-4vc9-m39g, CVE-2023-32059

Package Slug

pypi/vyper

Vulnerability

Function Call With Incorrect Order of Arguments

Description

Vyper is a Pythonic smart contract language for the Ethereum virtual machine. Prior to version 0.3.8, internal calls with default arguments are compiled incorrectly. Depending on the number of arguments provided in the call, the defaults are added not right-to-left, but left-to-right. If the types are incompatible, typechecking is bypassed. The ability to pass kwargs to internal functions is an undocumented feature that is not well known about. The issue is patched in version 0.3.8.

Affected Versions

All versions before 0.3.8

Solution

Upgrade to version 0.3.8 or above.

Last Modified

2023-05-15

source