CVE-2021-29434

Cross-site Scripting in pypi/wagtail

Identifier

CVE-2021-29434

Package Slug

pypi/wagtail

Vulnerability

Cross-site Scripting

Description

When saving the contents of a rich text field in the admin interface, Wagtail does not apply server-side checks to ensure that link URLs use a valid protocol. A malicious user with access to the admin interface could thus craft a POST request to publish content with javascript: URLs containing arbitrary code. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin. See referenced GitHub advisory for additional details, including a workaround. Patched versions have been released as Wagtail (for the branch) and Wagtail (for the current branch).

Affected Versions

All versions starting from 2.11.0 before 2.11.7, all versions starting from 2.12.0 before 2.12.4

Solution

Upgrade to versions 2.11.7, 2.12.4 or above.

Last Modified

2021-04-30

source