Advisory Database
  • Advisories
  • Dependency Scanning
  1. gem
  2. ›
  3. cgi
  4. ›
  5. CVE-2021-33621

CVE-2021-33621: HTTP response splitting in CGI

November 19, 2022 (updated November 4, 2025)

Ruby gem cgi.rb prior to versions 0.3.5, 0.2.2 and 0.1.0.2 allow HTTP header injection. If a CGI application using the CGI library inserts untrusted input into the HTTP response header, an attacker can exploit it to insert a newline character to split a header, and inject malicious content to deceive clients. This issue has been patched in versions 0.3.5, 0.2.2 and 0.1.0.2.

References

  • github.com/advisories/GHSA-vc47-6rqg-c7f5
  • github.com/rubysec/ruby-advisory-db/blob/master/gems/cgi/CVE-2021-33621.yml
  • hackerone.com/reports/1204695
  • lists.debian.org/debian-lts-announce/2023/06/msg00012.html
  • lists.debian.org/debian-lts-announce/2024/09/msg00000.html
  • lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/DQR7LWED6VAPD5ATYOBZIGJQPCUBRJBX
  • lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/THVTYHHEOVLQFCFHWURZYO7PVUPBHRZD
  • lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/YACE6ORF2QBXXBK2V2CM36D7TZMEJVAS
  • lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/DQR7LWED6VAPD5ATYOBZIGJQPCUBRJBX
  • lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/THVTYHHEOVLQFCFHWURZYO7PVUPBHRZD
  • lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/YACE6ORF2QBXXBK2V2CM36D7TZMEJVAS
  • nvd.nist.gov/vuln/detail/CVE-2021-33621
  • security.gentoo.org/glsa/202401-27
  • security.netapp.com/advisory/ntap-20221228-0004
  • www.ruby-lang.org/en/news/2022/11/22/http-response-splitting-in-cgi-cve-2021-33621

Code Behaviors & Features

Detect and mitigate CVE-2021-33621 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 0.1.0.2, all versions starting from 0.2.0 before 0.2.2, all versions starting from 0.3.0 before 0.3.5

Fixed versions

  • 0.3.5
  • 0.2.2
  • 0.1.0.2

Solution

Upgrade to versions 0.1.0.2, 0.2.2, 0.3.5 or above.

Impact 8.8 HIGH

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-436: Interpretation Conflict
  • CWE-74: Improper Neutralization of Special Elements in Output Used by a Downstream Component ('Injection')

Source file

gem/cgi/CVE-2021-33621.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Fri, 30 Oct 2026 12:15:33 +0000.