Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.apache.cloudstack/cloudstack
  4. ›
  5. CVE-2016-6813

CVE-2016-6813: Improper Authentication

February 6, 2018 (updated March 13, 2018)

Apache CloudStack to contain an API call designed to allow a user to register for the developer API. If a malicious user is able to determine the ID of another, non-root CloudStack user, the malicious user may be able to reset the API keys for the other user, in turn accessing their account and resources.

References

  • www.securityfocus.com/bid/93945
  • nvd.nist.gov/vuln/detail/CVE-2016-6813

Code Behaviors & Features

Detect and mitigate CVE-2016-6813 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 4.1.0 up to 4.8.1.0, version 4.9.0.0

Fixed versions

  • 4.8.1.1
  • 4.9.0.1

Solution

Upgrade to versions 4.8.1.1, 4.9.0.1 or above.

Impact 9.8 CRITICAL

CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-320

Source file

maven/org.apache.cloudstack/cloudstack/CVE-2016-6813.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sat, 07 Nov 2026 00:17:06 +0000.