CVE-2025-55017: Apache IoTDB has a Path Traversal vulnerability
(updated )
Improper Limitation of a Pathname to a Restricted Directory (‘Path Traversal’) vulnerability in Apache IoTDB.
This issue affects Apache IoTDB: from 2.0.0 before 2.0.6, from 1.0.0 before 1.3.6.
Users are recommended to upgrade to version 1.3.6 and 2.0.6, which fixes the issue.
References
- github.com/advisories/GHSA-xrvj-h9w2-3q69
- github.com/apache/iotdb/commit/6c27518610776be16dc998403918e978968a7325
- github.com/apache/iotdb/commit/9a15b5d13f5b19f13ddb46b799567fbabcb0e541
- github.com/apache/iotdb/pull/16097
- github.com/apache/iotdb/pull/16098
- github.com/apache/iotdb/releases/tag/v1.3.6
- github.com/apache/iotdb/releases/tag/v2.0.6
- lists.apache.org/thread/lk08wlxq9sp64mo8hw6wvjxd3bh3lpqg
- nvd.nist.gov/vuln/detail/CVE-2025-55017
Code Behaviors & Features
Detect and mitigate CVE-2025-55017 with GitLab Dependency Scanning
Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →