Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. @cap-js/postgres
  4. ›
  5. CVE-2026-46421

CVE-2026-46421: Supply chain compromise via malicious package versions (@cap-js/sqlite, @cap-js/postgres, @cap-js/db-service)

May 20, 2026

On April 29, 2026, compromised versions of @cap-js/sqlite@2.2.2, @cap-js/postgres@2.2.2, and @cap-js/db-service@2.10.1 were published. The malicious packages harvested credentials and attempted self-propagation. If a compromised version was installed, all credentials accessible on that machine (npm tokens, cloud provider credentials, SSH keys, GitHub PATs) should be considered compromised.

References

  • github.com/advisories/GHSA-pvw4-cvr4-97p8
  • github.com/cap-js/cds-dbs/security/advisories/GHSA-pvw4-cvr4-97p8
  • me.sap.com/notes/3747787
  • nvd.nist.gov/vuln/detail/CVE-2026-46421
  • www.sap.com/documents/2026/05/8203a8b9-4d7f-0010-bca6-c68f7e60039b.html
  • www.stepsecurity.io/blog/a-mini-shai-hulud-has-appeared

Code Behaviors & Features

Detect and mitigate CVE-2026-46421 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 2.2.2 before 2.3.0

Fixed versions

  • 2.3.0

Solution

Upgrade to version 2.3.0 or above.

Weakness

  • CWE-506: Embedded Malicious Code

Source file

npm/@cap-js/postgres/CVE-2026-46421.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Fri, 30 Oct 2026 12:15:24 +0000.