Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. jquery
  4. ›
  5. CVE-2012-6708

CVE-2012-6708: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

September 1, 2020 (updated September 15, 2021)

jQuery before 1.9.0 is vulnerable to Cross-site Scripting (XSS) attacks. The jQuery(strInput) function does not differentiate selectors from HTML in a reliable fashion. In vulnerable versions, jQuery determined whether the input was HTML by looking for the ‘<’ character anywhere in the string, giving attackers more flexibility when attempting to construct a malicious payload. In fixed versions, jQuery only deems the input to be HTML if it explicitly starts with the ‘<’ character, limiting exploitability only to attackers who can control the beginning of a string, which is far less common.

References

  • lists.opensuse.org/opensuse-security-announce/2020-03/msg00041.html
  • packetstormsecurity.com/files/153237/RetireJS-CORS-Issue-Script-Execution.html
  • packetstormsecurity.com/files/161972/Linksys-EA7500-2.0.8.194281-Cross-Site-Scripting.html
  • www.securityfocus.com/bid/102792
  • bugs.jquery.com/ticket/11290
  • bugs.jquery.com/ticket/12531
  • bugs.jquery.com/ticket/6429
  • bugs.jquery.com/ticket/9521
  • github.com/advisories/GHSA-2pqj-h3vj-pqgw
  • github.com/jquery/jquery/commit/05531fc4080ae24070930d15ae0cea7ae056457d
  • help.ecostruxureit.com/display/public/UADCE725/Security+fixes+in+StruxureWare+Data+Center+Expert+v7.6.0
  • lists.apache.org/thread.html/519eb0fd45642dcecd9ff74cb3e71c20a4753f7d82e2f07864b5108f@%3Cdev.drill.apache.org%3E
  • lists.apache.org/thread.html/b0656d359c7d40ec9f39c8cc61bca66802ef9a2a12ee199f5b0c1442@%3Cdev.drill.apache.org%3E
  • lists.apache.org/thread.html/f9bc3e55f4e28d1dcd1a69aae6d53e609a758e34d2869b4d798e13cc@%3Cissues.drill.apache.org%3E
  • nvd.nist.gov/vuln/detail/CVE-2012-6708
  • nvd.nist.gov/vuln/detail/CVE-2017-16011
  • snyk.io/vuln/npm:jquery:20120206
  • www.npmjs.com/advisories/329

Code Behaviors & Features

Detect and mitigate CVE-2012-6708 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 1.7.1 up to 1.8.3

Fixed versions

  • 1.9.0

Solution

Upgrade to version 1.9.0 or above.

Impact 6.1 MEDIUM

CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-78: Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection')
  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

npm/jquery/CVE-2012-6708.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Fri, 30 Oct 2026 12:16:51 +0000.